<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8" />
<script type="text/javascript">
var gform;gform||(document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0}),gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),gform.hooks[o][n].push({tag:i,callable:r,priority:t=null==t?10:t})},doHook:function(n,o,r){var t;if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[n][o]&&((o=gform.hooks[n][o]).sort(function(o,n){return o.priority-n.priority}),o.forEach(function(o){"function"!=typeof(t=o.callable)&&(t=window[t]),"action"==n?t.apply(null,r):r[0]=t.apply(null,r)})),"filter"==n)return r[0]},removeHook:function(o,n,t,i){var r;null!=gform.hooks[o][n]&&(r=(r=gform.hooks[o][n]).filter(function(o,n,r){return!!(null!=i&&i!=o.tag||null!=t&&t!=o.priority)}),gform.hooks[o][n]=r)}});
</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel='stylesheet' id='style-css-v1' href='/wp-content/themes/mensflair/style.css?ver=030822' type='text/css' media='all' />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>14 Luxury Luggage Brands Producing The Finest Suitcases (2022)</title><link rel='preload' href='https://mensflair.com/wp-content/themes/mensflair/resources/fonts/warnockpro-regular-webfont.woff2' as='font' type='font/woff2' crossorigin><link rel='preload' href='https://mensflair.com/wp-content/themes/mensflair/resources/fonts/warnockpro-semibold-webfont.woff2' as='font' type='font/woff2' crossorigin><link rel='preload' href='https://mensflair.com/wp-content/themes/mensflair/resources/fonts/myriadpro-regular-webfont.woff2' as='font' type='font/woff2' crossorigin><link rel='preload' href='https://mensflair.com/wp-content/themes/mensflair/resources/fonts/myriadpro-semibold-webfont.woff2' as='font' type='font/woff2' crossorigin>
<meta name="description" content="It&#039;s not the golden era of aviation but it doesn’t stop us travelling in style. These luxury luggage brands will instantly upgrade your airport style." />
<link rel="canonical" href="https://mensflair.com/luxury-luggage-brands/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="14 Luxury Luggage Brands Producing The Finest Suitcases (2022)" />
<meta property="og:description" content="It&#039;s not the golden era of aviation but it doesn’t stop us travelling in style. These luxury luggage brands will instantly upgrade your airport style." />
<meta property="og:url" content="https://mensflair.com/luxury-luggage-brands/" />
<meta property="og:site_name" content="Men&#039;s Flair" />
<meta property="article:publisher" content="https://www.facebook.com/MensFlair" />
<meta property="article:published_time" content="2022-09-15T08:00:42+00:00" />
<meta property="article:modified_time" content="2022-09-12T12:28:38+00:00" />
<meta property="og:image" content="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Ryan Thompson" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@MensFlair" />
<meta name="twitter:site" content="@MensFlair" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://mensflair.com/luxury-luggage-brands/#article","isPartOf":{"@id":"https://mensflair.com/luxury-luggage-brands/"},"author":{"name":"Ryan Thompson","@id":"https://mensflair.com/#/schema/person/6d6cccf0bc460bfc68e3a01ab8ebe77e"},"headline":"The Luxury Luggage Brands That Will Upgrade Your Airport Style","datePublished":"2022-09-15T08:00:42+00:00","dateModified":"2022-09-12T12:28:38+00:00","mainEntityOfPage":{"@id":"https://mensflair.com/luxury-luggage-brands/"},"wordCount":1847,"publisher":{"@id":"https://mensflair.com/#organization"},"image":{"@id":"https://mensflair.com/luxury-luggage-brands/#primaryimage"},"thumbnailUrl":"https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg","articleSection":["Men's Style","Shopping Guides"],"inLanguage":"en-GB"},{"@type":"WebPage","@id":"https://mensflair.com/luxury-luggage-brands/","url":"https://mensflair.com/luxury-luggage-brands/","name":"14 Luxury Luggage Brands Producing The Finest Suitcases (2022)","isPartOf":{"@id":"https://mensflair.com/#website"},"primaryImageOfPage":{"@id":"https://mensflair.com/luxury-luggage-brands/#primaryimage"},"image":{"@id":"https://mensflair.com/luxury-luggage-brands/#primaryimage"},"thumbnailUrl":"https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg","datePublished":"2022-09-15T08:00:42+00:00","dateModified":"2022-09-12T12:28:38+00:00","description":"It's not the golden era of aviation but it doesn’t stop us travelling in style. These luxury luggage brands will instantly upgrade your airport style.","breadcrumb":{"@id":"https://mensflair.com/luxury-luggage-brands/#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://mensflair.com/luxury-luggage-brands/"]}]},{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://mensflair.com/luxury-luggage-brands/#primaryimage","url":"https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg","contentUrl":"https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg","width":1920,"height":1080,"caption":"Globe-Trotter"},{"@type":"BreadcrumbList","@id":"https://mensflair.com/luxury-luggage-brands/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://mensflair.com/"},{"@type":"ListItem","position":2,"name":"The Luxury Luggage Brands That Will Upgrade Your Airport Style"}]},{"@type":"WebSite","@id":"https://mensflair.com/#website","url":"https://mensflair.com/","name":"Men&#039;s Flair","description":"Men&#039;s Style Guide &amp; Fashion Tips","publisher":{"@id":"https://mensflair.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://mensflair.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"Organization","@id":"https://mensflair.com/#organization","name":"Men's Flair","url":"https://mensflair.com/","sameAs":["https://www.facebook.com/MensFlair","https://twitter.com/MensFlair"],"logo":{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://mensflair.com/#/schema/logo/image/","url":"https://mensflair.com/wp-content/uploads/2022/05/mens-flair-black-logo.jpg","contentUrl":"https://mensflair.com/wp-content/uploads/2022/05/mens-flair-black-logo.jpg","width":1000,"height":118,"caption":"Men's Flair"},"image":{"@id":"https://mensflair.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://mensflair.com/#/schema/person/6d6cccf0bc460bfc68e3a01ab8ebe77e","name":"Ryan Thompson","url":"https://mensflair.com/author/ryan-thompson/"}]}</script>

<link rel="alternate" type="application/rss+xml" title="Men&#039;s Flair &raquo; Feed" href="https://mensflair.com/feed/" />

<script src="https://mensflair.com/wp-content/uploads/perfmatters/gtag.js" data-cfasync="false" data-wpfc-render="false" type="pmdelayedscript" async data-perfmatters-type="text/javascript" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script data-cfasync="false" data-wpfc-render="false" type="pmdelayedscript" data-perfmatters-type="text/javascript" data-no-optimize="1" data-no-defer="1" data-no-minify="1">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</script>

<style id='global-styles-inline-css' type='text/css'>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</style>
<script type="pmdelayedscript" src="https://mensflair.com/wp-content/plugins/google-analytics-premium/assets/js/frontend-gtag.min.js?ver=8.8.2" id="monsterinsights-frontend-script-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script data-cfasync="false" data-wpfc-render="false" type="pmdelayedscript" id="monsterinsights-frontend-script-js-extra" data-perfmatters-type="text/javascript" data-no-optimize="1" data-no-defer="1" data-no-minify="1">/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/mensflair.com","hash_tracking":"false","ua":"UA-2648649-1","v4_id":"G-9DLP32BYR6"};/* ]]> */
</script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<meta name="cdp-version" content="1.3.1" /><link rel="icon" href="https://mensflair.com/wp-content/uploads/2022/05/cropped-Artboard-3white--32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://mensflair.com/wp-content/uploads/2022/05/cropped-Artboard-3white--192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mensflair.com/wp-content/uploads/2022/05/cropped-Artboard-3white--180x180.jpg" />
<meta name="msapplication-TileImage" content="https://mensflair.com/wp-content/uploads/2022/05/cropped-Artboard-3white--270x270.jpg" />

</head>
<body class="post-template-default single single-post postid-15840 single-format-standard font-warnock text-base relative body-top text-body">
<div id="page" class="site min-h-mos-screen">
<div class="relative z-50">
<header id="top-nav" class="bg-white fixed top-0 left-0 right-0 px-6 h-18 flex items-center shadow-md" role="banner">
<div class="flex-1 items-center flex mx-auto max-w-screen-2xl">
<div class="flex-1 flex lg:hidden items-center">
<a class="flex items-center w-8 h-8 cursor-pointer" title="Menu" id="NavButton">
<svg xmlns="http://www.w3.org/2000/svg" class="menu-open block h-6 w-auto" viewBox="0 0 24 24" stroke="black" stroke-width="2" stroke-linecap="butt" stroke-linejoin="arcs">
<line x1="3" y1="12" x2="21" y2="12"></line>
<line x1="3" y1="6" x2="21" y2="6"></line>
<line x1="3" y1="18" x2="21" y2="18"></line>
</svg>
<svg xmlns="http://www.w3.org/2000/svg" class="menu-close hidden h-8 w-auto" viewBox="0 0 24 24" stroke="black" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="arcs">
<line x1="18" y1="6" x2="6" y2="18"></line>
<line x1="6" y1="6" x2="18" y2="18"></line>
</svg>
</a>
</div>
<div class="flex-1 flex lg:flex-initial items-center justify-center">
<a href="/" title="Men&#039;s Flair: Modern Man&#039;s Fashion Guide" data-wpel-link="internal">
<svg xmlns="http://www.w3.org/2000/svg" class="h-5 lg:h-6 w-auto" viewBox="0 0 347.63281 40.73828">
<g id="Layer_1" data-name="Layer 1" />
<g id="Layer_2" data-name="Layer 2">
<g id="Layer_1-2" data-name="Layer 1">
<g>
<g>
<path d="M32.33887,39.83789v-.95996c4.31982-.83984,4.61963-1.25977,4.67969-7.55957l.17969-24.83887c-4.55957,10.61914-13.25928,30.77832-14.21924,33.3584h-.8999c-1.08008-2.82031-8.75977-21.83887-13.13965-32.39844-.83984,18.29883-.95996,25.43848-.8999,27.41895,.12012,2.63965,1.43994,3.2998,6.06006,4.01953v.95996H0v-.95996c4.19971-.59961,5.04004-1.62012,5.3999-3.89941,.2998-1.98047,.54004-5.2207,1.97998-28.97949,.05957-1.43945-.47998-3.65918-5.64014-4.19922V.83984H13.61963l12.1792,27.71875L38.21826,.83984h11.33984v.95996c-4.97998,.89941-5.3999,1.31934-5.33984,6.95898l.23975,22.55957c.06006,6,.30029,6.65918,5.1001,7.55957v.95996h-17.21924Z" />
<path d="M85.61768,30.41797c-.2998,2.10059-1.37988,7.98047-1.73975,9.41992h-29.27881v-.95996c5.15967-.71973,5.57959-1.01953,5.57959-6.35938V8.15918c0-5.39941-.2998-5.87988-4.55957-6.35938V.83984h18.1792c5.87988,0,8.21973-.06055,8.69971-.12012,.06006,2.2793,.2998,6.11914,.59961,8.69922l-.95996,.18066c-.47949-1.5-1.25977-3.7207-2.57959-5.28027-1.08008-1.32031-2.3999-1.67969-5.93994-1.67969h-4.49951c-1.26025,0-1.5,.23926-1.5,1.43945v14.33984h5.81982c4.73975,0,4.91943-1.32031,5.75977-5.04004h.95996v11.87988h-.95996c-.84033-3.54004-1.02002-5.04004-5.75977-5.04004h-5.81982v12.7793c0,4.2002,.8999,4.97949,4.61963,5.04004h3.54004c3.53955,0,4.37988-.48047,5.87988-2.09961,1.07959-1.2002,2.03955-3.24023,3.05957-5.7002l.8999,.17969Z" />
<path d="M131.2168,1.7998c-3.95996,.83984-4.85986,1.5-4.97949,5.5791-.06006,1.86035-.18018,3.36035-.18018,9.59961v23.69922h-1.5L97.61816,8.2793v15.35938c0,5.58008,.06006,7.31934,.18018,9.2998,.23975,4.0791,.6001,5.15918,6.17969,5.93945v.95996h-13.85938v-.95996c4.49951-.66016,4.97949-1.55957,5.21973-5.75977,.12012-2.16016,.2998-4.5,.2998-9.47949V7.91895c0-1.25977-.35986-2.39941-.95996-3.17969-1.56006-2.09961-2.63965-2.51953-5.27979-2.93945V.83984h11.45947l23.2793,27.17871v-11.04004c0-6.23926-.18018-7.7998-.24023-9.47949-.17969-4.19922-1.55957-5.04004-6.77979-5.69922V.83984h14.09961v.95996Z" />
<path d="M162.77637,9.35938c-1.25977-4.98047-4.13965-7.97949-8.75928-7.97949-3.6001,0-5.64014,2.45996-5.64014,6.2998,0,3.7793,2.1001,5.5791,7.25977,8.63867,5.16016,3.06055,9.77979,6.2998,9.77979,12.59961,0,6.90039-5.81982,11.82031-13.79932,11.82031-2.93994,0-5.75977-.60059-9.05957-1.44043-.36035-1.13965-1.26025-8.21973-1.32031-9.17969l.95996-.17969c1.32031,5.21973,4.85986,9.41895,10.37988,9.41895,4.13965,0,5.93945-2.81934,5.93945-6.83887,0-3.78027-2.21973-6.48047-6.47949-9.05957-5.3999-3.30078-9.77979-6.36035-9.77979-12.47949,0-6.18066,4.85986-10.97949,12.83936-10.97949,3.66016,0,6.35986,.71973,7.62012,.7793,.23975,2.21973,.59961,5.51953,1.01953,8.39941l-.95996,.18066Z" />
<path d="M206.75586,9.83887c-.35986-1.55957-1.08008-3.2998-1.85986-4.61914-1.08008-1.86035-2.64014-2.58008-6.54004-2.58008h-4.19971c-1.7998,0-2.21973,.2998-2.21973,2.09961v14.2793h6.59961c4.37988,0,4.73975-.95996,5.75977-5.15918h.8999v12.11914h-.95996c-1.14014-4.08008-1.31982-5.16016-5.69971-5.16016h-6.59961v10.55957c0,6.24023,.35986,6.59961,5.45947,7.5v.95996h-17.69922v-.95996c4.37988-.78027,4.7998-1.25977,4.7998-7.5V8.87891c0-5.93945-.41992-6.23926-4.7998-7.0791V.83984h18.83936c5.87988,0,7.97949-.06055,8.63965-.12012,.06006,1.08008,.24023,5.81934,.54004,8.99902l-.95996,.12012Z" />
<path d="M244.01562,30.05859c-.54004,2.75977-2.16016,8.87891-2.52002,9.7793h-28.37891v-.95996c5.27979-.78027,5.57959-1.25977,5.57959-6.41992V8.21875c0-5.33984-.41992-5.63965-4.97949-6.41895V.83984h17.33887v.95996c-4.49951,.83984-4.91943,1.25977-4.91943,6.41895v25.67969c0,3.7793,1.02002,4.13965,4.01953,4.13965h3.6001c3.23975,0,4.07959-.48047,5.63965-1.91992,1.25977-1.2002,2.64014-3.83984,3.71973-6.2998l.90039,.24023Z" />
<path d="M267.83496,39.83789v-.95996c4.14014-.90039,4.2002-1.55957,3.12012-4.67969-.71973-1.98047-1.73975-5.09961-3-8.45996h-10.97949c-1.02002,2.75977-1.97998,5.45996-2.69971,7.62012-1.37988,4.01953-.8999,4.55957,4.31982,5.51953v.95996h-13.01953v-.95996c3.95996-.66016,4.73975-1.44043,6.83984-6.7793L264.83545,.41992l1.61963-.24023c3.78027,10.61914,7.67969,21.05859,11.63965,31.55859,2.1001,5.75977,2.7002,6.35938,6.35938,7.13965v.95996h-16.61914Zm-5.21973-29.51855c-1.85986,4.97949-3.23975,9.05957-4.91943,13.49902h9.53955l-4.62012-13.49902Z" />
<path d="M286.73535,39.83789v-.95996c4.5-.78027,4.7998-1.2002,4.7998-6.7793V8.51953c0-5.58008-.41992-6.06055-4.7998-6.71973V.83984h17.09961v.95996c-4.37988,.7793-4.86035,1.0791-4.86035,6.71973v23.51855c0,5.75977,.36035,6.05957,4.86035,6.83984v.95996h-17.09961Z" />
<path d="M347.45312,40.25781h-2.7002c-7.19922-.2998-9.11914-1.67969-11.15918-4.85938-2.09961-3.24023-3.95996-6.59961-5.87988-10.32031-1.32031-2.51953-2.21973-3.23926-4.25977-3.23926h-.90039v10.55957c0,5.03906,.36035,5.51953,4.80078,6.47949v.95996h-16.91992v-.95996c4.43945-.95996,4.7998-1.32031,4.7998-6.47949V8.21875c0-5.03906-.36035-5.69922-4.7998-6.41895V.83984h16.13965c4.91992,0,7.91992,.54004,10.37988,2.2793,2.2793,1.56055,3.59961,4.02051,3.59961,7.08008,0,6.05957-4.62012,8.75977-7.62012,10.01953,.90039,1.62012,4.08008,7.13965,5.75977,9.83984,2.28027,3.65918,3.05957,4.85938,4.37988,6.41992,1.37988,1.61914,2.21973,2.15918,4.55957,2.93945l-.17969,.83984Zm-23.69922-19.79883c2.87988,0,4.98047-.24023,6.41992-1.62012,1.67969-1.55957,2.40039-3.66016,2.40039-7.13965,0-6.95996-3.48047-9.47949-6.90039-9.47949-1.25977,0-2.09961,.12012-2.45996,.41992-.41992,.2998-.66016,.71973-.66016,1.91992v15.89941h1.2002Z" />
</g>
<circle cx="136.56934" cy="4.0957" r="3" />
</g>
</g>
</g>
</svg>
</a>
</div>
<div class="items-center flex-1 lg:flex lg:pl-10 font-gill-sans tracking-widest uppercase font-semibold text-sm relative">
<div class="hidden lg:flex items-center">
<a href="/latest/" rel="nofollow" class="mr-8" data-wpel-link="internal">Latest</a>
<a href="/category/style-advice/" class="mr-8" data-wpel-link="internal">Style</a>
<a href="/category/hair/" class="mr-8" data-wpel-link="internal">Hair</a>
<a href="/category/grooming/" class="mr-8" data-wpel-link="internal">Grooming</a>
<a href="/category/watches/" class="mr-8" data-wpel-link="internal">Watches</a>
<a href="/category/shopping-guide/" class="mr-8" data-wpel-link="internal">Shopping Guides</a>
</div>
<div class="flex items-center ml-auto">
<a class="ml-auto cursor-pointer flex items-center" title="Search" id="SearchButton">
<svg xmlns="http://www.w3.org/2000/svg" class="search-open h-6 ml-auto w-auto" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="arcs"><circle cx="11" cy="11" r="8"></circle><line x1="21" y1="21" x2="16.65" y2="16.65"></line></svg>
<svg xmlns="http://www.w3.org/2000/svg" class="search-close h-8 w-auto" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="1" stroke-linecap="butt" stroke-linejoin="arcs" style="display: none;"><line x1="18" y1="6" x2="6" y2="18"></line><line x1="6" y1="6" x2="18" y2="18"></line></svg>
</a>
</div>
<div class="flex items-center search-container hidden lg:mr-6">
<div class="flex items-center relative z-20 h-full w-full">
<svg xmlns="http://www.w3.org/2000/svg" class="h-6 w-auto" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="1.5" stroke-linecap="butt" stroke-linejoin="arcs"><circle cx="11" cy="11" r="8"></circle><line x1="21" y1="21" x2="16.65" y2="16.65"></line></svg>
<form action="/" method="GET" class="flex-1 flex items-center lg:mx-4 ml-4 border-b border-solid border-black">
<input id="searchInput" value="" name="s" placeholder="Search..." type="search" class="bg-white py-2 w-full outline-none appearance-none text-base font-semibold uppercase tracking-widest" />

</form>
</div>
</div>
</div>
</div>
</header>
<div id="searchOverlay" class="fixed hidden inset-0 cursor-pointer lg:opacity-0" style="background-color:rgba(0,0,0,0.4);z-index:-1;"></div>
<nav class="main-navigation fixed left-0 w-full border-t border-solid border-black">
<div class="flex min-h-screen relative pointer-events-none">
<div class="flex flex-col bg-white w-full p-6 pointer-events-auto">
<ul class="main-nav border-b border-solid border-grey mb-6 pt-4 pb-6 text-6xl text-center font-bold"> 
<li><a href="/latest/" class="block" rel="nofollow" data-wpel-link="internal">Latest</a></li>
<li><a href="/category/style-advice/" class="block" data-wpel-link="internal">Style</a></li>
<li><a href="/category/hair/" class="block" data-wpel-link="internal">Hair</a></li>
<li><a href="/category/grooming/" class="block" data-wpel-link="internal">Grooming</a></li>
<li><a href="/category/watches/" class="block" data-wpel-link="internal">Watches</a></li>
</ul>
<ul class="border-b border-solid border-grey mb-6 pb-6 text-xl font-semibold text-center">
<li><a href="/category/shopping-guide/" class="block pt-2" data-wpel-link="internal">Shopping Guides</a></li>
<li><a href="/category/mens-fashion-trends/" class="block pt-2" data-wpel-link="internal">Fashion Trends</a></li>
<li><a href="/category/how-to-wear/" class="block pt-2" data-wpel-link="internal">How To Wear</a></li>
<li><a href="/outfits/" class="block pt-2" data-wpel-link="internal">Outfit Gallery</a></li>

</ul>
<ul class="mb-6 pb-4 text-sm font-normal text-center justify-center uppercase flex">
<li><a href="/about-us/" rel="nofollow" class="inline-block" data-wpel-link="internal">About Us</a></li>
<li><a href="/contact/" rel="nofollow" class="inline-block px-4" data-wpel-link="internal">Contact Us</a></li>
<li><a href="/advertise/" rel="nofollow" class="inline-block" data-wpel-link="internal">Advertise</a></li>
</ul>
</div>
</div>
</nav>
</div>
<div id="content">
<main class="post-content">
<article id="post-15840" class="post-15840 post type-post status-publish format-standard has-post-thumbnail hentry category-style-advice category-shopping-guide">
<div class="w-full h-full min-h-featured md:h-140 lg:h-175 relative img-cover">
<picture class="nolazy min-h-featured wp-post-image sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.avif 1920w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-500x281.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-900x506.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-400x225.avif 400w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-768x432.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-420x236.avif 420w" sizes="(max-width: 1920px) 100vw, 1920px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.webp 1920w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-500x281.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-900x506.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-400x225.webp 400w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-768x432.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-420x236.webp 420w" sizes="(max-width: 1920px) 100vw, 1920px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg 1920w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-420x236.jpg 420w" sizes="(max-width: 1920px) 100vw, 1920px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg" class="nolazy min-h-featured wp-post-image sp-no-webp" alt="The Luxury Luggage Brands That Will Upgrade Your Airport Style" height="1080" width="1920" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain.jpg 1920w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsMain-420x236.jpg 420w" sizes="(max-width: 1920px) 100vw, 1920px"></picture> <div class="mx-auto max-w-screen-2xl relative">
<span class="featureCredit text-center xl:text-right w-full absolute right-0 bottom-0">
Credit: Globe-Trotter </span>
</div>
</div>
<div class="py-6 px-6 mt-2 lg:mt-12 flex">
<div class="w-full max-w-screen-2xl mx-auto text-left flex">
<div class="article lg:pr-8 xl:pr-20">
<div class="text-center lg:text-left">
<h1 class="tracking-tight article-title">The Luxury Luggage Brands That Will Upgrade Your Airport Style</h1>
<p class="leadin text-lg font-light md:text-xl mb-6 md:mb-8 font-gill-sans">We might not be in the golden era of aviation but that doesn’t stop us travelling in style. Today’s luxury luggage options are as plentiful as they are sophisticated, ready for an aspiring generation of globe-hoppers.</p>
<div class="the-author py-3 font-gill-sans uppercase text-sm font-bold tracking-wider mb-12">
<p>Words by: <a href="/author/the-editors/" rel="nofollow" class="underline" data-wpel-link="internal">Men's Flair Editors</a></p>
</div>
</div>
<div class="article-copy">
<p>There used to be a time not all that long ago when airline passengers would get dressed up for a transatlantic flight. The fact that they could smoke cigars on the plane, and would be served up lobster thermidor swilled down with chilled champagne, were excuses enough to raise the style bar. Their suitcases, too, tended to be beautifully built, and built to last.</p>
<p>Today’s travellers could probably take a few notes on airborne dress codes, but that&#8217;s a separate article altogether. One simple yet very effective way to stand out from the madding airport crowd is by way of your luggage.</p>
<p>In a sea of cheap polycarbonate carcasses on wheels, an outstanding luxury trolley case is like a beacon of sophistication. It says you travel well, discerningly moving from one classy place to another. It also says you&#8217;re not short of a few, which seems to be biomarker no.1 in today&#8217;s literal human race. But moreover than that, a luxury case or bag shows that you care; that you’re attentive to the small details; that you have an appreciation for design and functionality.</p>
<p>A great case sets you apart from the sprawling mass of poor suitcases out there, which is just the shot of confidence one needs to dampen the anxiety of getting through a modern airport. So with all that said, we’ve compiled a list of our favourite life-affirming luxury luggage brands to elevate the flying experience.</p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="rimowa">Rimowa</h2>
<p><a href="https://www.rimowa.com/gb/en/original/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone wp-image-16895 size-large sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-900x1125.jpg" loading="lazy" class="alignnone wp-image-16895 size-large sp-no-webp" alt="Two Rimowa luxury aluminium wheeled suitcases" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit1.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-1' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.rimowa.com/gb/en/original/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-1-16849"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-1-16849" alt="Rimowa Original Check-In L" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands5.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-1-16849'>
Rimowa Original Check-In L
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.rimowa.com/gb/en/classic/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-1-16850"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-1-16850" alt="Rimowa Classic Check-In L" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands6.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-1-16850'>
Rimowa Classic Check-In L
</figcaption></figure></div>
<p>Even before Alexandre Arnault took over Rimowa, after it joined the LVMH stable in 2017, the heritage German luggage maker was still very much considered luxury. Founded in 1898 in Cologne, the label is of course best known for its super-lightweight but extremely rugged aluminium cases, complete with patented multi-wheel system and those distinctive grooves.</p>
<p>They look as if they were built for astronauts, or hitmen, oozing with no-nonsense industrial minimalism. And yes, you’re going to pay for the privilege of wheeling one along, but with a lifetime guarantee, a Rimowa case is more investment than divestment.</p>
<p>While we think the original aluminium cases are unmatched, keep your eyes peeled for the limited-edition collaborations (which tend to sell-out immediately). Recent hook-ups have included Off-White, Supreme, Daniel Arsham and Dior.</p>
<p><a class="button" href="https://www.rimowa.com/gb/en/all-luggage/" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Rimowa</a></p>
<h2 id="louis-vuitton">Louis Vuitton</h2>
<p><a href="https://uk.louisvuitton.com/eng-gb/men/travel/horizon/_/N-twjyjeb" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16982 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/lv-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16982 sp-no-webp" alt="Two luxury Louis Vuitton wheeled holdall cases" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/lv-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-2' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://uk.louisvuitton.com/eng-gb/men/travel/horizon/_/N-twjyjeb" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-2-16847"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-2-16847" alt="Louis Vuitton Horizon 70" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands3.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-2-16847'>
Louis Vuitton Horizon 70
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://uk.louisvuitton.com/eng-gb/men/travel/horizon/_/N-twjyjeb" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-2-16846"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-2-16846" alt="Louis Vuitton Horizon 55" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands4.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-2-16846'>
Louis Vuitton Horizon 55
</figcaption></figure></div>
<p>It’s easy to forget that the Louis Vuitton brand started life as a luggage maker. Back in 1834, Mr Vuitton was a dab hand at the construction of luxury trunks. As the upper classes began to develop a thirst for travel and exploration, Vuitton came upon the idea of constructing sturdy rectangular cases that could be easily stacked, rather than the rounded style that was available at the time.</p>
<p>You can still pick up these vintage trunks at auction, but we’re more interested in the luggage that Louis Vuitton makes today &#8211; namely the rolling cases, all of which were designed in collaboration with award-winning designer Marc Newson.</p>
<p>The pick of the lot is the Horizon collection, which comes in three different sizes, all dutifully emblazoned in the iconic monogram, as well as Damier check styles.</p>
<p><a class="button" href="https://uk.louisvuitton.com/eng-gb/men/travel/horizon/_/N-twjyjeb" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Louis Vuitton</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="aviteur">Aviteur</h2>
<p><a href="https://aviteur.com/collections/all" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16983 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/avituer-case-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/avituer-case-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/avituer-case.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/avituer-case-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/avituer-case-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16983 sp-no-webp" alt="Man with luxury Aviteur wheeled suitcase" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/avituer-case-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/avituer-case.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-3' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://aviteur.com/collections/all" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-3-16863"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-3-16863" alt="Aviteur Carry-on" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands13.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-3-16863'>
Aviteur Carry-on
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://aviteur.com/collections/all" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-3-16864"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-3-16864" alt="Aviteur Carry-On" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands14.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-3-16864'>
Aviteur Carry-On
</figcaption></figure></div>
<p>Definitions of &#8216;luxury&#8217; vary. For some it is the craftsmanship; for others the brand cachet; for others still, the exclusivity. There&#8217;s absolutely no denying then that Aviteur is a maker of truly luxurious luggage.</p>
<p>Founded by Patricia Gucci &#8211; the first woman to join Gucci’s board of directors, and the daughter of Aldo Gucci &#8211; Aviteur’s luggage is all entirely handmade from exquisite fabrics and materials, with no expense spared for the tiniest of details.</p>
<p>The flagship product is the Aviteur Carry-on, which comes in three different treatments of handcut calfskin woven leather. It also features wheel casters forged from aviation-grade aluminium for maximum stability and longevity, as well as a unique translucent Lucite trolley handle.</p>
<p>A blend of tradition and futurism, Aviteur is extremely pricey but exclusivity this well designed always comes at a cost.</p>
<p><a class="button" href="https://aviteur.com/collections/all" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Aviteur</a></p>
<h2 id="paravel">Paravel</h2>
<p><a href="https://www.selfridges.com/GB/en/cat/paravel/bags/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16984 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16984 sp-no-webp" alt="Man with luxury Paravel green wheeled case" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/paravel-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-4' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.selfridges.com/GB/en/cat/paravel/bags/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-4-16868"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-4-16868" alt="Paravel Aviator Shell Carry-On Suitcase" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands16.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-4-16868'>
Paravel Aviator Shell Carry-On Suitcase
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.libertylondon.com/uk/brands/p/paravel/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-4-16869"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-4-16869" alt="Paravel Aviator Carry-On Case" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands15.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-4-16869'>
Paravel Aviator Carry-On Case
</figcaption></figure></div>
<p>Co-founded by Indré Rockefeller and Andy Krantz in 2016, Paravel has put sustainability at the forefront of its immaculate carbon-neutral luggage construction. The company produces luxury Aviator cases made with shells moulded from recycled polycarbonate, handles crafted from recycled aircraft-grade aluminium, and linings woven with fibres sourced from recycled plastic water bottles.</p>
<p>Design-wise, the cases are a treat, available in minimalistic black or four other classy bi-colour options.</p>
<p><a class="button" href="https://www.selfridges.com/GB/en/cat/paravel/bags/" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Selfridges</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="victorinox">Victorinox</h2>
<p><a href="https://www.victorinox.com/uk/en/Products/Travel-Gear/c/TRG?ScrollPosition=0&amp;maxResults=30" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16985 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16985 sp-no-webp" alt="Man carrying Victorinox black wheeled suitcase up flight of stairs" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/vitorinox-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-5' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.victorinox.com/uk/en/Products/Travel-Gear/c/TRG?ScrollPosition=359&amp;maxResults=30" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-5-16872"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-5-16872" alt="Victorinox Lexicon Framed Series Medium Hardside Case" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands18.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-5-16872'>
Victorinox Lexicon Framed Series Medium Hardside Case
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.victorinox.com/uk/en/Products/Travel-Gear/c/TRG?ScrollPosition=359&amp;maxResults=30" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-5-16873"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-5-16873" alt="Victorinox Airox Frequent Flyer Hardside Carry-On" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands17.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-5-16873'>
Victorinox Airox Frequent Flyer Hardside Carry-On
</figcaption></figure></div>
<p>For a company that has been producing pocket knives for over 125 years, Swiss brand Victorinox might not have bells and whistles of some of the names on this list, but it sure knows the ins-and-outs of precise construction.</p>
<p>Victorinox&#8217;s carry-on cases and hold luggage are the definition of functional, crafted from SORPLAS™, a high-performance recycled polycarbonate by Sony Semiconductor Solutions Corporation, as well as 100% pure virgin polycarbonate. They are the type of cases that will withstand the rigours of frequent flying and then some, giving you ultimate peace of mind wherever you decide to go next.</p>
<p><a class="button" href="https://www.victorinox.com/uk/en/Products/Travel-Gear/c/TRG?ScrollPosition=0&amp;maxResults=30" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Victorinox</a></p>
<h2 id="steamline-luggage">Steamline Luggage</h2>
<p><a href="https://steamlineluggage.com/collections/luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16986 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16986 sp-no-webp" alt="Man sitting with three luxury Steamline Luggage trunks" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/steamline-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-6' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://steamlineluggage.com/collections/luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-6-16876"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-6-16876" alt="Steamline Luggage The Architect Check In Spinner" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands19.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-6-16876'>
Steamline Luggage The Architect Check In Spinner
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://steamlineluggage.com/collections/luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-6-16875"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-6-16875" alt="Steamline Luggage The Industrialist Carryon" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands20.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-6-16875'>
Steamline Luggage The Industrialist Carryon
</figcaption></figure></div>
<p>While the vast majority of today&#8217;s cases come in the form of modern tech materials on four wheels, there are still some luxury brands for whom the suitcase (remember those?) retains an enduring appeal.</p>
<p>Steamline Luggage is one such brand, founded in 2005 by Sara Banks and still going strong, producing stunning, nostalgia-rich cases in sumptuous colourways. Timeless and elegant, Steamline’s all-leather designs come in all manner of different sizes and shapes, and come in sets defined by titles such as The Industrialist, the Editor and the Architect, to name a few.</p>
<p>The interiors are beautifully designed, too, with a neat hanging travel kit also included. If you love vintage design, Steamline is a no-brainer.</p>
<p><a class="button" href="https://steamlineluggage.com/collections/luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Steamline Luggage</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="t-anthony">T. Anthony</h2>
<p><a href="https://tanthony.com/collections/travel-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16987 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16987 sp-no-webp" alt="Bell boy with luxury T.Anthony wheeled suitcase" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/tanthony-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-7' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://tanthony.com/collections/travel-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-7-16879"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-7-16879" alt="T Anthony Wheeled 1 Suiter" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands22.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-7-16879'>
T Anthony Wheeled 1 Suiter
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://tanthony.com/collections/travel-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-7-16880"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-7-16880" alt="T Anthony 4 Wheel International Carry On" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands21.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-7-16880'>
T Anthony 4 Wheel International Carry On
</figcaption></figure></div>
<p>Founded in New York in 1948, T. Antony has had an illustrious past, creating luggage for many a celebrity. While many brands have shifted towards hardcase shells, T. Anthony has stuck with a rugged 3-ply canvas wheeled case with full-grain leather trim as its poster boy.</p>
<p>Understated from a design point of view, T. Anthony’s soft cases are meticulously built, while its leather cases are something else ($17,000 for an alligator wheelie anyone?).</p>
<p><a class="button" href="https://tanthony.com/collections/travel-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: T. Anthony</a></p>
<h2 id="away">Away</h2>
<p><a href="https://www.awaytravel.com/uk/en/shop/suitcases" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16988 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/away-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/away-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/away-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/away-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/away-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16988 sp-no-webp" alt="Two Away carry-on wheeled suitcases in blue" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/away-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/away-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-8' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.awaytravel.com/uk/en/shop/suitcases" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-8-16882"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-8-16882" alt="Away The Medium" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands23.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-8-16882'>
Away The Medium
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.awaytravel.com/uk/en/shop/suitcases" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-8-16883"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-8-16883" alt="Away The Large Aluminum Edition" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands24.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-8-16883'>
Away The Large Aluminum Edition
</figcaption></figure></div>
<p>Beautifully minimalistic and extremely functional, Away has quickly made a name for itself producing functional modern cases for the seasoned stylish traveller.</p>
<p>Functional is the key here, because Away pioneered the ability for one’s luggage to charge one&#8217;s devices. Featuring stunning aluminium cases as well as super-durable polycarbonate styles, Away’s spinner designs are excellent options for the business traveller or any parent that understands the necessity of fully charged devices when on the move.</p>
<p><a class="button" href="https://www.awaytravel.com/uk/en/shop/suitcases" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Away</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="brics">Bric’s</h2>
<p><a href="https://www.brics.it/uk/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16989 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/brics-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16989 sp-no-webp" alt="Bric;s luxury wheeled suitcase and tote bag" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/brics-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-9' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.brics.it/uk/luggage.html" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-9-16887"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-9-16887" alt="Bric’s ZH Check in Luggage 30" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands25.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-9-16887'>
Bric’s ZH Check in Luggage 30
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.brics.it/uk/luggage.html" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-9-16886"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-9-16886" alt="Bric’s ZH Continental Carry On" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands26.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-9-16886'>
Bric’s ZH Continental Carry On
</figcaption></figure></div>
<p>Still a family-run business today, Bric&#8217;s (the name comes from the founder, Mario Briccola) has been providing <a href="https://mensflair.com/italian-style-men/" data-wpel-link="internal">discerning Italians</a> with the finest luggage since 1952. Based near Lake Como, Bric’s aesthetic is pretty classic, with a range of polycarbonate and soft case carry-ons and stowaways featuring nicely finished leather trimmings.</p>
<p>Our favourite styles however come from the anodised aluminium collection, which is actually a collaboration with the American luggage maker Zero Halliburton.</p>
<p><a class="button" href="https://www.brics.it/uk/" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Bric&#8217;s</a></p>
<h2 id="horizn-studios">Horizn Studios</h2>
<p><a href="https://www.matchesfashion.com/mens/designers/horizn-studios" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16990 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16990 sp-no-webp" alt="Man charging phone using Horizn Studios carry-on case" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/horizn-luggge.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-10' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://horizn-studios.co.uk/en/collections/luggage/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-10-16890"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-10-16890" alt="Horizn Studios Circle One" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands27.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-10-16890'>
Horizn Studios Circle One
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.matchesfashion.com/mens/designers/horizn-studios" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-10-16891"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-10-16891" alt="Horizn Studios M5 Smart Hardshell Cabin Suitcase" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands28.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-10-16891'>
Horizn Studios M5 Smart Hardshell Cabin Suitcase
</figcaption></figure></div>
<p>German luggage brand Horizn Studios was one of the first makers to launch a removable battery pack for device charging. So it comes as no surprise that the company has continued to innovate, not least when it comes to sustainability and materials, including waterproof tarpaulin, vegan Hi-Core shell and waterproof ballistic nylon. I</p>
<p>ts latest ground-breaking project is called Circle One, a line of hard shell cases made from BioX, a 100% plant-based and biodegradable material designed to be repaired and never replaced. According to the company, &#8220;BioX features a multiaxial and multi-density flax-fibre weave. Flax is Europe’s strongest and most productive renewable fibre &#8211; suspended in resin, its tensile strength is three times higher than that of aluminium&#8221;. The Circle One collection looks the part too, available in four understated classy tones.</p>
<p><a class="button" href="https://www.matchesfashion.com/mens/designers/horizn-studios" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: MATCHESFASHION</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="tumi">Tumi</h2>
<p><a href="https://www.selfridges.com/GB/en/cat/tumi/bags/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone wp-image-16893 size-large sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-900x1125.jpg" loading="lazy" class="alignnone wp-image-16893 size-large sp-no-webp" alt="Man wheeling a compact silver aluminium case by Tumi" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit3.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-11' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.selfridges.com/GB/en/cat/tumi/bags/?pn=1&amp;scrollToProductId=R03812815_IRON_ALT10" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-11-16852"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-11-16852" alt="Tumi Continental Carry-On 19 Degree Aluminium Suitcase" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands7.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-11-16852'>
Tumi Continental Carry-On 19 Degree Aluminium Suitcase
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://uk.tumi.com/luggage/checked-luggage/" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-11-16853"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-11-16853" alt="" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands8.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-11-16853'>
Tumi Worldwide Trip 4 Wheeled Packing Case
</figcaption></figure></div>
<p>Founded in New Jersey in 1975, Tumi takes its name from a mythical knife of Peru (the founder did a stint in the Peace Corps in the South American nation). The brand has been producing excellent, tech-first bags from day one.</p>
<p>Each new Tumi product undergoes in excess of 30 tests before it is released to the market to ensure that it is more than a match for the rigours of travel. Tumi makes all manner of luggage, from ballistic grade nylon bags to the very swish 19-degree aluminium spinners, which feature anti-microbial linings and exteriors.</p>
<p>They’re some of the finest looking cases on this list and they’re packed with features, too.</p>
<p><a class="button" href="https://www.selfridges.com/GB/en/cat/tumi/bags/" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Selfridges</a></p>
<h2 id="vocier">Vocier</h2>
<p><a href="https://vocier.com/collections/carry-on-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16991 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16991 sp-no-webp" alt="Vocier luxury luggage in front of and on an Eames chair" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/vocier-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-12' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://vocier.com/collections/carry-on-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-12-16856"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-12-16856" alt="Vocier C38 Pure Carry-on" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands10.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-12-16856'>
Vocier C38 Pure Carry-on
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://vocier.com/collections/carry-on-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-12-16857"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-12-16857" alt="Vocier CP38 Luggage Set" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands9.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-12-16857'>
Vocier CP38 Luggage Set
</figcaption></figure></div>
<p>Vocier is an award-winning German luxury luggage brand which produces elegant, retro-styled carry-on cases that offer a zero-crease promise thanks to a clever packing system <a href="https://mensflair.com/lounge-suit-dress-code/" data-wpel-link="internal">for suits</a>.</p>
<p>Perfect for the business traveller, Vocier’s cases are built from a tough nylon exterior with leather details and come with a lifetime guarantee. Minimalistic in appearance but punching well above their price point.</p>
<p><a class="button" href="https://vocier.com/collections/carry-on-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Vocier</a></p>
<div class="banner-articles"><div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div></div>
<h2 id="fabbrica-pelletterie-milano">Fabbrica Pelletterie Milano</h2>
<p><a href="https://www.farfetch.com/uk/shopping/men/fpm-fabbrica-pelletterie-milano/items.aspx?page=1&amp;view=90&amp;sort=3&amp;category=136363" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone size-large wp-image-16992 sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-900x1125.jpg" loading="lazy" class="alignnone size-large wp-image-16992 sp-no-webp" alt="Two luxury FPM hard shell wheeled suitcases" height="1125" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/fpm-luggage.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-13' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.matchesfashion.com/mens/designers/fpm-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-13-16861"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-13-16861" alt="FPM Milano Spinner 68 Stud-Embellished Suitcase" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands11.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-13-16861'>
FPM Milano Spinner 68 Stud-Embellished Suitcase
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.matchesfashion.com/mens/designers/fpm-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-13-16860"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-13-16860" alt="FPM Milano Bank Zip Spinner 80 Check-In Suitcase" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrands12.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-13-16860'>
FPM Milano Bank Zip Spinner 80 Check-In Suitcase
</figcaption></figure></div>
<p>Ever since 1946, iconic Italian luggage brand Fabbrica Pelletterie Milano &#8211; otherwise known as FPM &#8211; has been making some of the world’s finest luggage. Although it started out back then as a leather specialist, the FPM of today is a masterful crafter of aluminium cases, exemplified by its &#8216;Bank&#8217; collection &#8211; all made in Italy and inspired by vintage trunks.</p>
<p>Visually exquisite, the Bank cases have been designed by Marc Sadler and feature a stunning corrugated aluminium shell with contrast leather handle details. But even better than that is the special one-off collaboration with hypercar maker Pagani, which resulted in the Bank Carbon. As the name suggests, the case is further embellished with carbon fibre elements throughout. Nice for a weekend away in the Zonda.</p>
<p><a class="button" href="https://www.farfetch.com/uk/shopping/men/fpm-fabbrica-pelletterie-milano/items.aspx?page=1&amp;view=90&amp;sort=3&amp;category=136363" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Farfetch</a></p>
<h2 id="globe-trotter">Globe-Trotter</h2>
<p><a href="https://www.globe-trotter.com/collections/check-in-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture loading="lazy" class="alignnone wp-image-16894 size-large sp-no-webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-900x900.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-500x500.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-768x768.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-420x420.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2.avif 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-900x900.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-500x500.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-768x768.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-420x420.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2.webp 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-900x900.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-500x500.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-768x768.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-420x420.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-900x900.jpg" loading="lazy" class="alignnone wp-image-16894 size-large sp-no-webp" alt="Two classic beige and tan leather luxury Globe-Trotter trunks" height="900" width="900" srcset="https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-900x900.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-500x500.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-768x768.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2-420x420.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/LuxuryLuggageBrandsEdit2.jpg 1000w" sizes="(max-width: 900px) 100vw, 900px"></picture></a></p>
<div id='gallery-14' class='gallery-type-default flex overflow-y-auto mb-6 md:mb-8 md:grid md:grid-cols-2 gap-8 pb-6 md:pb-0'><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.globe-trotter.com/collections/check-in-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-14-16844"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-14-16844" alt="Globe-Trotter Centenary Large Check-In - 4 Wheels" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands1.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-14-16844'>
Globe-Trotter Centenary Large Check-In &#8211; 4 Wheels
</figcaption></figure><figure class='gallery-item w-2/3 md:w-full flex-shrink-0'><a href="https://www.globe-trotter.com/collections/carry-on-luggage-suitcases" data-wpel-link="external" target="_blank" rel="nofollow noopener"><picture class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-14-16843"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-500x625.avif 500w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-900x1125.avif 900w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-768x960.avif 768w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-420x525.avif 420w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2.avif 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-500x625.webp 500w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-900x1125.webp 900w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-768x960.webp 768w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-420x525.webp 420w,https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2.webp 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-500x625.jpg" class="attachment-medium size-medium sp-no-webp" loading="lazy" aria-describedby="gallery-14-16843" alt="Globe-Trotter Centenary Carry-On - 4 Wheels" height="625" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-500x625.jpg 500w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-900x1125.jpg 900w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-768x960.jpg 768w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2-420x525.jpg 420w, https://mensflair.com/wp-content/uploads/2022/08/LuxuryLuggageBrands2.jpg 1000w" sizes="(max-width: 500px) 100vw, 500px"></picture></a>
<figcaption class='caption wp-caption-text gallery-caption' id='gallery-14-16843'>
Globe-Trotter Centenary Carry-On &#8211; 4 Wheels
</figcaption></figure></div>
<p>Doing the old-school case makers proud since 1897, <a href="https://mensflair.com/british-fashion-clothing-brands/" data-wpel-link="internal">British heritage brand</a> Globe-Trotter is recognisable all over the world for its iconic cases &#8211; all still handmade in Hertfordshire, England using traditional machinery and artisanal techniques.</p>
<p>We say British, but it was actually founded in Germany, only to move to the UK in 1932. With a clientele list featuring the likes of Queen Elizabeth II (who took the cases on her honeymoon in 1947) and Sir Winston Churchill, it&#8217;s easy to see why Globe-Trotter is still so popular today, despite bucking the trend for hi-tech aluminium cases.</p>
<p>Globe-Trotter&#8217;s designs are full of character, wearing every trip they go on. Made from vulcanised fibreboard with leather trimmings, these carry-ons are head-turners wherever they go.</p>
<p><a class="button" href="https://www.globe-trotter.com/collections/check-in-luggage" data-wpel-link="external" target="_blank" rel="nofollow noopener">Shop now: Globe-Trotter</a></p>
</div>
</div>
<div id="sidebar" class="pt-2 hidden lg:block">
<div class="sticky-sidebar">
<div class="banner-skyscraper hidden lg:block mb-12" style="min-height:600px;">
<div class="ws_widget_banner" style="width: 300px; height: 600px" data-url="https://visit.ws/widget/banner" data-publisher="115"></div>
</div>
<div class="w-full relative overflow-hidden pt-8 pb-4 px-6" style="background:#f7f7f7">
<h2 class="font-semibold tracking-tight text-4xl text-center" style="line-height:1.1">Learn how to dress better</h2>
<p class="text-center mb-4 mt-2">Get the latest style advice, outfit inspiration &amp; buying guides in your inbox each week.</p>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<div class='gf_browser_chrome gform_wrapper gravity-theme sidebar-form_wrapper w-full_wrapper' id='gform_wrapper_7'><div id='gf_7' class='gform_anchor' tabindex='-1'></div>
<div class='gform_heading'>
<p class='gform_required_legend'>&quot;<span class="gfield_required gfield_required_asterisk">*</span>&quot; indicates required fields</p>
</div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_7' id='gform_7' class='sidebar-form w-full' action='/luxury-luggage-brands/#gf_7' novalidate>
<div class='gform_body gform-body'><div id='gform_fields_7' class='gform_fields top_label form_sublabel_below description_below'><div id="field_7_3" class="gfield gfield--width-full gfield_contains_required field_sublabel_below field_description_below hidden_label gfield_visibility_visible" data-js-reload="field_7_3"><label class='gfield_label' for='input_7_3'>Name<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_text'><input name='input_3' id='input_7_3' type='text' value='' class='large' placeholder='Your name' aria-required="true" aria-invalid="false" /> </div></div><div id="field_7_2" class="gfield gfield--width-full gfield_contains_required field_sublabel_below field_description_below hidden_label gfield_visibility_visible" data-js-reload="field_7_2"><label class='gfield_label' for='input_7_2'>Email<span class="gfield_required"><span class="gfield_required gfield_required_asterisk">*</span></span></label><div class='ginput_container ginput_container_email'>
<input name='input_2' id='input_7_2' type='email' value='' class='large' placeholder='Your email' aria-required="true" aria-invalid="false" />
</div></div></div></div>
<div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_7' class='gform_button button' value='Subscribe' onclick='if(window["gf_submitting_7"]){return false;}  if( !jQuery("#gform_7")[0].checkValidity || jQuery("#gform_7")[0].checkValidity()){window["gf_submitting_7"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_7"]){return false;} if( !jQuery("#gform_7")[0].checkValidity || jQuery("#gform_7")[0].checkValidity()){window["gf_submitting_7"]=true;}  jQuery("#gform_7").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=7&amp;title=&amp;description=&amp;tabindex=0' />
<input type='hidden' class='gform_hidden' name='is_submit_7' value='1' />
<input type='hidden' class='gform_hidden' name='gform_submit' value='7' />
<input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
<input type='hidden' class='gform_hidden' name='state_7' value='WyJbXSIsIjMxMGMxMTAwMDA0YzMyOTNlNmFkM2I3ZmE0YmEyZTg4Il0=' />
<input type='hidden' class='gform_hidden' name='gform_target_page_number_7' id='gform_target_page_number_7' value='0' />
<input type='hidden' class='gform_hidden' name='gform_source_page_number_7' id='gform_source_page_number_7' value='1' />
<input type='hidden' name='gform_field_values' value='' />
</div>
<p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="151" /><script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>
</div>
<iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_7' id='gform_ajax_frame_7' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() {gformInitSpinner( 7, 'https://mensflair.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery('#gform_ajax_frame_7').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_7');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_7').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_7').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_7').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_7').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_7').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_7').val();gformInitSpinner( 7, 'https://mensflair.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery(document).trigger('gform_page_loaded', [7, current_page]);window['gf_submitting_7'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_7').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_7').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [7]);window['gf_submitting_7'] = false;wp.a11y.speak(jQuery('#gform_confirmation_message_7').text());}, 50);}else{jQuery('#gform_7').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [7, current_page]);} );} );
</script>
</div>
</div>
</div>
</div>
</div>
</article>

<div class="px-4">
<div class="max-w-screen-2xl mx-auto pb-8 lg:pt-4">
<div class="banner-responsive">
<div class="ws_widget_banner" data-url="https://visit.ws/widget/banner" data-publisher="115"></div>
</div>
</div>
</div>
<div class="px-6">
<div class="max-w-screen-2xl mx-auto mt-4 pb-4">
<div class="pb-4 md:pb-8 flex items-center justify-between tracking-wider">
<h2 class="homepage w-full text-center relative text-lg md:text-2xl font-gill-sans uppercase font-bold"><span>Read Next</span></h2>
</div>
<div class="overflow-hidden">
<div class="flex -ml-6 md:-ml-8 overflow-y-auto md:flex-wrap mb-2 md:mb-8">
<article class="w-2/3 md:w-1/2 lg:w-1/4 pl-6 md:pl-8 flex-shrink-0">
<a href="https://mensflair.com/suede-jackets/" alt="The Ultimate Guide To Men&#8217;s Suede Jackets" data-wpel-link="internal">
<div class="w-full">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-500x281.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-900x506.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-400x225.avif 400w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-768x432.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-420x236.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain.avif 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-500x281.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-900x506.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-400x225.webp 400w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-768x432.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-420x236.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain.webp 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-500x281.jpg" class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy" alt="The Ultimate Guide To Men’s Suede Jackets" height="281" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/SuedeJacketsBrandsMain.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px"></picture> </div>
<h3 class="text-lg md:text-xl my-4 text-left font-semibold lg:font-normal pr-4 md:pr-0">The Ultimate Guide To Men&#8217;s Suede Jackets</h3>
</a>
</article>
<article class="w-2/3 md:w-1/2 lg:w-1/4 pl-6 md:pl-8 flex-shrink-0">
<a href="https://mensflair.com/what-to-wear-club/" alt="How Men Should Dress For A Club In 2022: 36 Night Out Outfits" data-wpel-link="internal">
<div class="w-full">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-500x281.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-900x506.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-400x225.avif 400w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-768x432.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-420x236.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1.avif 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-500x281.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-900x506.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-400x225.webp 400w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-768x432.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-420x236.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1.webp 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-500x281.jpg" class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy" alt="How a man should dress for a club" height="281" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/mens-club-outfits-1.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px"></picture> </div>
<h3 class="text-lg md:text-xl my-4 text-left font-semibold lg:font-normal pr-4 md:pr-0">How Men Should Dress For A Club In 2022: 36 Night Out Outfits</h3>
</a>
</article>
<article class="w-2/3 md:w-1/2 lg:w-1/4 pl-6 md:pl-8 flex-shrink-0">
<a href="https://mensflair.com/semi-formal-attire/" alt="The Semi-Formal Attire Dress Code: A Modern Man’s Guide For 2022" data-wpel-link="internal">
<div class="w-full">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-500x281.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-900x506.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-400x225.avif 400w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-768x432.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-420x236.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1.avif 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-500x281.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-900x506.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-400x225.webp 400w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-768x432.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-420x236.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1.webp 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-500x281.jpg" class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy" alt="Men's semi formal summer attire: light blue textured suit with white shirt" height="281" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/semi-formal-attire-men-1.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px"></picture> </div>
<h3 class="text-lg md:text-xl my-4 text-left font-semibold lg:font-normal pr-4 md:pr-0">The Semi-Formal Attire Dress Code: A Modern Man’s Guide For 2022</h3>
</a>
</article>
<article class="w-2/3 md:w-1/2 lg:w-1/4 pl-6 md:pl-8 flex-shrink-0">
<a href="https://mensflair.com/how-to-clean-suede-boots-shoes/" alt="How To Clean Suede Boots &#038; Shoes (Without Ruining Them)" data-wpel-link="internal">
<div class="w-full">
<picture class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-500x281.avif 500w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-900x506.avif 900w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-400x225.avif 400w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-768x432.avif 768w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-420x236.avif 420w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes.avif 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-500x281.webp 500w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-900x506.webp 900w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-400x225.webp 400w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-768x432.webp 768w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-420x236.webp 420w,https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes.webp 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-500x281.jpg" class="attachment-medium size-medium wp-post-image sp-no-webp" loading="lazy" alt="Man wearing clean suede Chelsea boots" height="281" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-500x281.jpg 500w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-900x506.jpg 900w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-400x225.jpg 400w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-768x432.jpg 768w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-1536x864.jpg 1536w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes-420x236.jpg 420w, https://mensflair.com/wp-content/uploads/2022/09/clean-suede-boots-shoes.jpg 1920w" sizes="(max-width: 500px) 100vw, 500px"></picture> </div>
<h3 class="text-lg md:text-xl my-4 text-left font-semibold lg:font-normal pr-4 md:pr-0">How To Clean Suede Boots &#038; Shoes (Without Ruining Them)</h3>
</a>
</article>
</div>
</div>
</div>
</div>
<nav class="hidden post-navigation">
<a class="previous-post-link" href="https://mensflair.com/suede-jackets/" rel="prev" data-wpel-link="internal">Previous Article</a>
</nav>

<script>if (!('_ws_init' in window)) { var s = document.createElement("script"); s.async = true; s.src = "https://visit.ws/js/ws.js"; document.body.appendChild(s); } else { window._ws_init(); }</script>
</main>
</div>
</div>

<div class="newsletter-popup hidden fixed inset-0 z-50 flex items-center justify-center">
<div class="absolute inset-0 cursor-pointer" style="background-color:rgba(0,0,0,0.4);" id="NewsletterOverlay"></div>
<div class="w-full relative bg-white md:bg-light-grey flex max-w-screen-lg mx-6">
<a class="newsletter-close cursor-pointer absolute top-0 right-0 p-2 md:p-4 z-10" title="Close Newsletter">
<svg xmlns="http://www.w3.org/2000/svg" class="h-8 w-auto" viewBox="0 0 24 24" fill="none" stroke="currentColor" stroke-width="1" stroke-linecap="butt" stroke-linejoin="arcs"><line x1="18" y1="6" x2="6" y2="18"></line><line x1="6" y1="6" x2="18" y2="18"></line></svg>
</a>
<div class="hidden md:block w-1/3">
<picture class="w-full sp-no-webp" loading="lazy"><source srcset="https://mensflair.com/wp-content/uploads/2022/03/news-popup.avif 500w,https://mensflair.com/wp-content/uploads/2022/03/news-popup-420x630.avif 420w,https://mensflair.com/wp-content/uploads/2022/03/news-popup-450x675.avif 450w" sizes="(max-width: 500px) 100vw, 500px" type="image/avif"><source srcset="https://mensflair.com/wp-content/uploads/2022/03/news-popup.webp 500w,https://mensflair.com/wp-content/uploads/2022/03/news-popup-420x630.webp 420w,https://mensflair.com/wp-content/uploads/2022/03/news-popup-450x675.webp 450w" sizes="(max-width: 500px) 100vw, 500px" type="image/webp"><source srcset="https://mensflair.com/wp-content/uploads/2022/03/news-popup.jpg 500w, https://mensflair.com/wp-content/uploads/2022/03/news-popup-420x630.jpg 420w, https://mensflair.com/wp-content/uploads/2022/03/news-popup-450x675.jpg 450w" sizes="(max-width: 500px) 100vw, 500px" type="image/jpeg"><img src="https://mensflair.com/wp-content/uploads/2022/03/news-popup.jpg" class="w-full sp-no-webp" loading="lazy" alt="" height="750" width="500" srcset="https://mensflair.com/wp-content/uploads/2022/03/news-popup.jpg 500w, https://mensflair.com/wp-content/uploads/2022/03/news-popup-420x630.jpg 420w, https://mensflair.com/wp-content/uploads/2022/03/news-popup-450x675.jpg 450w" sizes="(max-width: 500px) 100vw, 500px"></picture> </div>
<div class="m-auto relative w-full md:w-2/3 px-6 md:px-10 py-12 text-center md:text-left">
<h2 class="font-bold tracking-tight text-4xl md:text-6xl">Learn how to dress better</h2>
<p class="md:text-xl pt-2">Join over 10,000 stylish men who get the latest fashion advice, outfit inspiration and buying guides direct to their inbox every Friday.</p>
<div class='gf_browser_chrome gform_wrapper gravity-theme inpage-form_wrapper flex_wrapper w-full_wrapper my-4_wrapper items-start_wrapper' id='gform_wrapper_5'><div id='gf_5' class='gform_anchor' tabindex='-1'></div><form method='post' enctype='multipart/form-data' target='gform_ajax_frame_5' id='gform_5' class='inpage-form flex w-full my-4 items-start' action='/luxury-luggage-brands/#gf_5' novalidate>
<div class='gform_body gform-body'><div id='gform_fields_5' class='gform_fields top_label form_sublabel_below description_below'><div id="field_5_3" class="gfield gfield--width-full gfield_contains_required field_sublabel_below field_description_below hidden_label gfield_visibility_visible" data-js-reload="field_5_3"><label class='gfield_label' for='input_5_3'>Name<span class="gfield_required"><span class="gfield_required gfield_required_text">(Required)</span></span></label><div class='ginput_container ginput_container_text'><input name='input_3' id='input_5_3' type='text' value='' class='large' placeholder='Your name' aria-required="true" aria-invalid="false" /> </div></div><div id="field_5_2" class="gfield gfield--width-full gfield_contains_required field_sublabel_below field_description_below hidden_label gfield_visibility_visible" data-js-reload="field_5_2"><label class='gfield_label' for='input_5_2'>Email<span class="gfield_required"><span class="gfield_required gfield_required_text">(Required)</span></span></label><div class='ginput_container ginput_container_email'>
<input name='input_2' id='input_5_2' type='email' value='' class='large' placeholder='Your email' aria-required="true" aria-invalid="false" />
</div></div></div></div>
<div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_5' class='gform_button button' value='Subscribe' onclick='if(window["gf_submitting_5"]){return false;}  if( !jQuery("#gform_5")[0].checkValidity || jQuery("#gform_5")[0].checkValidity()){window["gf_submitting_5"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_5"]){return false;} if( !jQuery("#gform_5")[0].checkValidity || jQuery("#gform_5")[0].checkValidity()){window["gf_submitting_5"]=true;}  jQuery("#gform_5").trigger("submit",[true]); }' /> <input type='hidden' name='gform_ajax' value='form_id=5&amp;title=&amp;description=&amp;tabindex=0' />
<input type='hidden' class='gform_hidden' name='is_submit_5' value='1' />
<input type='hidden' class='gform_hidden' name='gform_submit' value='5' />
<input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
<input type='hidden' class='gform_hidden' name='state_5' value='WyJbXSIsIjMxMGMxMTAwMDA0YzMyOTNlNmFkM2I3ZmE0YmEyZTg4Il0=' />
<input type='hidden' class='gform_hidden' name='gform_target_page_number_5' id='gform_target_page_number_5' value='0' />
<input type='hidden' class='gform_hidden' name='gform_source_page_number_5' id='gform_source_page_number_5' value='1' />
<input type='hidden' name='gform_field_values' value='' />
</div>
 <p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_2" name="ak_js" value="23" /><script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">document.getElementById( "ak_js_2" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>
</div>
<iframe style='display:none;width:0px;height:0px;' src='about:blank' name='gform_ajax_frame_5' id='gform_ajax_frame_5' title='This iframe contains the logic required to handle Ajax powered Gravity Forms.'></iframe>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() {gformInitSpinner( 5, 'https://mensflair.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery('#gform_ajax_frame_5').on('load',function(){var contents = jQuery(this).contents().find('*').html();var is_postback = contents.indexOf('GF_AJAX_POSTBACK') >= 0;if(!is_postback){return;}var form_content = jQuery(this).contents().find('#gform_wrapper_5');var is_confirmation = jQuery(this).contents().find('#gform_confirmation_wrapper_5').length > 0;var is_redirect = contents.indexOf('gformRedirect(){') >= 0;var is_form = form_content.length > 0 && ! is_redirect && ! is_confirmation;var mt = parseInt(jQuery('html').css('margin-top'), 10) + parseInt(jQuery('body').css('margin-top'), 10) + 100;if(is_form){jQuery('#gform_wrapper_5').html(form_content.html());if(form_content.hasClass('gform_validation_error')){jQuery('#gform_wrapper_5').addClass('gform_validation_error');} else {jQuery('#gform_wrapper_5').removeClass('gform_validation_error');}setTimeout( function() { /* delay the scroll by 50 milliseconds to fix a bug in chrome */ jQuery(document).scrollTop(jQuery('#gform_wrapper_5').offset().top - mt); }, 50 );if(window['gformInitDatepicker']) {gformInitDatepicker();}if(window['gformInitPriceFields']) {gformInitPriceFields();}var current_page = jQuery('#gform_source_page_number_5').val();gformInitSpinner( 5, 'https://mensflair.com/wp-content/plugins/gravityforms/images/spinner.svg' );jQuery(document).trigger('gform_page_loaded', [5, current_page]);window['gf_submitting_5'] = false;}else if(!is_redirect){var confirmation_content = jQuery(this).contents().find('.GF_AJAX_POSTBACK').html();if(!confirmation_content){confirmation_content = contents;}setTimeout(function(){jQuery('#gform_wrapper_5').replaceWith(confirmation_content);jQuery(document).scrollTop(jQuery('#gf_5').offset().top - mt);jQuery(document).trigger('gform_confirmation_loaded', [5]);window['gf_submitting_5'] = false;wp.a11y.speak(jQuery('#gform_confirmation_message_5').text());}, 50);}else{jQuery('#gform_5').append(contents);if(window['gformRedirect']) {gformRedirect();}}jQuery(document).trigger('gform_post_render', [5, current_page]);} );} );
</script>
<p class="font-gill-sans text-sm tracking-wide">By signing up to our newsletter you agree to our <a href="/privacy/" class="underline" data-wpel-link="internal">privacy policy</a>.</p>
</div>
</div>
</div>

<footer class="bg-black text-white font-medium font-gill-sans uppercase pt-16 pb-8 px-6 overflow-hidden">
<div class="w-full flex flex-wrap max-w-screen-2xl m-auto tracking-widest text-sm text-center">
<div class="w-full md:w-1/3 flex-shrink-0 pb-8">
<h4 class="text-lg mb-2">Company</h4>
<a href="/about-us/" data-wpel-link="internal">About Us</a>
<a href="/advertise/" rel="nofollow" data-wpel-link="internal">Advertise</a>
<a href="/contact/" data-wpel-link="internal">Contact Us</a>
<a href="/privacy/" data-wpel-link="internal">Privacy Policy</a>
<a href="/terms/" data-wpel-link="internal">Terms &amp; Conditions</a>
</div>
<div class="w-full md:w-1/3 flex-shrink-0 pb-8">
<h4 class="text-lg mb-2">Sections</h4>
<a href="/" data-wpel-link="internal">Men's Fashion</a>
<a href="/category/style-advice/" data-wpel-link="internal">Men’s Style</a>
<a href="/category/grooming/" data-wpel-link="internal">Men’s Grooming</a>
<a href="/category/hair/" data-wpel-link="internal">Men’s Haircuts</a>
<a href="/category/watches/" data-wpel-link="internal">Men’s Watches</a>
</div>
<div class="w-full md:w-1/3 flex-shrink-0 pb-8">
<h4 class="text-lg mb-2">Popular</h4>

<a href="/category/how-to-wear/" data-wpel-link="internal">How To Wear</a>
<a href="/category/shopping-guide/" data-wpel-link="internal">Buying Guides</a>
<a href="/outfits/" data-wpel-link="internal">Outfit Galleries</a>

</div>
</div>
<div class="w-full max-w-screen-2xl text-center m-auto md:pt-8">
<svg xmlns="http://www.w3.org/2000/svg" class="w-auto h-4 md:h-5 m-auto" viewBox="0 0 347.63281 40.73828">
<g id="Layer_1" data-name="Layer 1" />
<g id="Layer_2" data-name="Layer 2">
<g id="Layer_1-2" data-name="Layer 1">
<g>
<g>
<path d="M32.33887,39.83789v-.95996c4.31982-.83984,4.61963-1.25977,4.67969-7.55957l.17969-24.83887c-4.55957,10.61914-13.25928,30.77832-14.21924,33.3584h-.8999c-1.08008-2.82031-8.75977-21.83887-13.13965-32.39844-.83984,18.29883-.95996,25.43848-.8999,27.41895,.12012,2.63965,1.43994,3.2998,6.06006,4.01953v.95996H0v-.95996c4.19971-.59961,5.04004-1.62012,5.3999-3.89941,.2998-1.98047,.54004-5.2207,1.97998-28.97949,.05957-1.43945-.47998-3.65918-5.64014-4.19922V.83984H13.61963l12.1792,27.71875L38.21826,.83984h11.33984v.95996c-4.97998,.89941-5.3999,1.31934-5.33984,6.95898l.23975,22.55957c.06006,6,.30029,6.65918,5.1001,7.55957v.95996h-17.21924Z" fill="#fff" />
<path d="M85.61768,30.41797c-.2998,2.10059-1.37988,7.98047-1.73975,9.41992h-29.27881v-.95996c5.15967-.71973,5.57959-1.01953,5.57959-6.35938V8.15918c0-5.39941-.2998-5.87988-4.55957-6.35938V.83984h18.1792c5.87988,0,8.21973-.06055,8.69971-.12012,.06006,2.2793,.2998,6.11914,.59961,8.69922l-.95996,.18066c-.47949-1.5-1.25977-3.7207-2.57959-5.28027-1.08008-1.32031-2.3999-1.67969-5.93994-1.67969h-4.49951c-1.26025,0-1.5,.23926-1.5,1.43945v14.33984h5.81982c4.73975,0,4.91943-1.32031,5.75977-5.04004h.95996v11.87988h-.95996c-.84033-3.54004-1.02002-5.04004-5.75977-5.04004h-5.81982v12.7793c0,4.2002,.8999,4.97949,4.61963,5.04004h3.54004c3.53955,0,4.37988-.48047,5.87988-2.09961,1.07959-1.2002,2.03955-3.24023,3.05957-5.7002l.8999,.17969Z" fill="#fff" />
<path d="M131.2168,1.7998c-3.95996,.83984-4.85986,1.5-4.97949,5.5791-.06006,1.86035-.18018,3.36035-.18018,9.59961v23.69922h-1.5L97.61816,8.2793v15.35938c0,5.58008,.06006,7.31934,.18018,9.2998,.23975,4.0791,.6001,5.15918,6.17969,5.93945v.95996h-13.85938v-.95996c4.49951-.66016,4.97949-1.55957,5.21973-5.75977,.12012-2.16016,.2998-4.5,.2998-9.47949V7.91895c0-1.25977-.35986-2.39941-.95996-3.17969-1.56006-2.09961-2.63965-2.51953-5.27979-2.93945V.83984h11.45947l23.2793,27.17871v-11.04004c0-6.23926-.18018-7.7998-.24023-9.47949-.17969-4.19922-1.55957-5.04004-6.77979-5.69922V.83984h14.09961v.95996Z" fill="#fff" />
<path d="M162.77637,9.35938c-1.25977-4.98047-4.13965-7.97949-8.75928-7.97949-3.6001,0-5.64014,2.45996-5.64014,6.2998,0,3.7793,2.1001,5.5791,7.25977,8.63867,5.16016,3.06055,9.77979,6.2998,9.77979,12.59961,0,6.90039-5.81982,11.82031-13.79932,11.82031-2.93994,0-5.75977-.60059-9.05957-1.44043-.36035-1.13965-1.26025-8.21973-1.32031-9.17969l.95996-.17969c1.32031,5.21973,4.85986,9.41895,10.37988,9.41895,4.13965,0,5.93945-2.81934,5.93945-6.83887,0-3.78027-2.21973-6.48047-6.47949-9.05957-5.3999-3.30078-9.77979-6.36035-9.77979-12.47949,0-6.18066,4.85986-10.97949,12.83936-10.97949,3.66016,0,6.35986,.71973,7.62012,.7793,.23975,2.21973,.59961,5.51953,1.01953,8.39941l-.95996,.18066Z" fill="#fff" />
<path d="M206.75586,9.83887c-.35986-1.55957-1.08008-3.2998-1.85986-4.61914-1.08008-1.86035-2.64014-2.58008-6.54004-2.58008h-4.19971c-1.7998,0-2.21973,.2998-2.21973,2.09961v14.2793h6.59961c4.37988,0,4.73975-.95996,5.75977-5.15918h.8999v12.11914h-.95996c-1.14014-4.08008-1.31982-5.16016-5.69971-5.16016h-6.59961v10.55957c0,6.24023,.35986,6.59961,5.45947,7.5v.95996h-17.69922v-.95996c4.37988-.78027,4.7998-1.25977,4.7998-7.5V8.87891c0-5.93945-.41992-6.23926-4.7998-7.0791V.83984h18.83936c5.87988,0,7.97949-.06055,8.63965-.12012,.06006,1.08008,.24023,5.81934,.54004,8.99902l-.95996,.12012Z" fill="#fff" />
<path d="M244.01562,30.05859c-.54004,2.75977-2.16016,8.87891-2.52002,9.7793h-28.37891v-.95996c5.27979-.78027,5.57959-1.25977,5.57959-6.41992V8.21875c0-5.33984-.41992-5.63965-4.97949-6.41895V.83984h17.33887v.95996c-4.49951,.83984-4.91943,1.25977-4.91943,6.41895v25.67969c0,3.7793,1.02002,4.13965,4.01953,4.13965h3.6001c3.23975,0,4.07959-.48047,5.63965-1.91992,1.25977-1.2002,2.64014-3.83984,3.71973-6.2998l.90039,.24023Z" fill="#fff" />
<path d="M267.83496,39.83789v-.95996c4.14014-.90039,4.2002-1.55957,3.12012-4.67969-.71973-1.98047-1.73975-5.09961-3-8.45996h-10.97949c-1.02002,2.75977-1.97998,5.45996-2.69971,7.62012-1.37988,4.01953-.8999,4.55957,4.31982,5.51953v.95996h-13.01953v-.95996c3.95996-.66016,4.73975-1.44043,6.83984-6.7793L264.83545,.41992l1.61963-.24023c3.78027,10.61914,7.67969,21.05859,11.63965,31.55859,2.1001,5.75977,2.7002,6.35938,6.35938,7.13965v.95996h-16.61914Zm-5.21973-29.51855c-1.85986,4.97949-3.23975,9.05957-4.91943,13.49902h9.53955l-4.62012-13.49902Z" fill="#fff" />
<path d="M286.73535,39.83789v-.95996c4.5-.78027,4.7998-1.2002,4.7998-6.7793V8.51953c0-5.58008-.41992-6.06055-4.7998-6.71973V.83984h17.09961v.95996c-4.37988,.7793-4.86035,1.0791-4.86035,6.71973v23.51855c0,5.75977,.36035,6.05957,4.86035,6.83984v.95996h-17.09961Z" fill="#fff" />
<path d="M347.45312,40.25781h-2.7002c-7.19922-.2998-9.11914-1.67969-11.15918-4.85938-2.09961-3.24023-3.95996-6.59961-5.87988-10.32031-1.32031-2.51953-2.21973-3.23926-4.25977-3.23926h-.90039v10.55957c0,5.03906,.36035,5.51953,4.80078,6.47949v.95996h-16.91992v-.95996c4.43945-.95996,4.7998-1.32031,4.7998-6.47949V8.21875c0-5.03906-.36035-5.69922-4.7998-6.41895V.83984h16.13965c4.91992,0,7.91992,.54004,10.37988,2.2793,2.2793,1.56055,3.59961,4.02051,3.59961,7.08008,0,6.05957-4.62012,8.75977-7.62012,10.01953,.90039,1.62012,4.08008,7.13965,5.75977,9.83984,2.28027,3.65918,3.05957,4.85938,4.37988,6.41992,1.37988,1.61914,2.21973,2.15918,4.55957,2.93945l-.17969,.83984Zm-23.69922-19.79883c2.87988,0,4.98047-.24023,6.41992-1.62012,1.67969-1.55957,2.40039-3.66016,2.40039-7.13965,0-6.95996-3.48047-9.47949-6.90039-9.47949-1.25977,0-2.09961,.12012-2.45996,.41992-.41992,.2998-.66016,.71973-.66016,1.91992v15.89941h1.2002Z" fill="#fff" />
</g>
<circle cx="136.56934" cy="4.0957" r="3" fill="#fff" />
</g>
</g>
</g>
</svg>
<p class="pt-4 uppercase text-xs font-semibold tracking-widest">&copy;2022 <a href="/" class="inline" data-wpel-link="internal">Men's Flair</a>: The Modern Man's Style Guide</p>
</div>
</footer>

<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">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</script><script type="pmdelayedscript" src="https://mensflair.com/wp-content/plugins/auto-load-next-post/assets/js/libs/scrollspy.min.js?ver=1.5.14" id="auto-load-next-post-scrollspy-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-content/plugins/auto-load-next-post/assets/js/libs/jquery.history.js?ver=1.5.14" id="auto-load-next-post-history-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" id="auto-load-next-post-script-js-extra" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
/* <![CDATA[ */
var auto_load_next_post_params = {"alnp_version":"1.5.14","alnp_content_container":"main.post-content","alnp_title_selector":"h1.article-title","alnp_navigation_container":"nav.post-navigation","alnp_comments_container":"div#comments","alnp_remove_comments":"no","alnp_google_analytics":"yes","alnp_event_on_load":"","alnp_event_on_entering":"","alnp_is_customizer":"","alnp_load_in_footer":"1"};
/* ]]> */
</script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-content/plugins/auto-load-next-post/assets/js/frontend/auto-load-next-post.min.js?ver=1.5.14" id="auto-load-next-post-script-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" src="https://mensflair.com/wp-content/plugins/perfmatters/vendor/instant-page/instantpage.js?ver=1.9.9" id="perfmatters-instant-page-js" data-perfmatters-type="text/javascript" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-content/themes/mensflair/resources/js/sitescripts.js?ver=130622" id="mf-scripts-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9" id="regenerator-runtime-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0" id="wp-polyfill-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/dom-ready.min.js?ver=d996b53411d1533a84951212ab6ac4ff" id="wp-dom-ready-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/hooks.min.js?ver=c6d64f2cb8f5c6bb49caca37f8828ce3" id="wp-hooks-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/i18n.min.js?ver=ebee46757c6a411e38fd079a7ac71d94" id="wp-i18n-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" id="wp-i18n-js-after" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type="pmdelayedscript" id="wp-a11y-js-translations" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", {"translation-revision-date":"2022-07-05 17:05:41+0000","generator":"GlotPress\/4.0.0-alpha.1","domain":"messages","locale_data":{"messages":{"":{"domain":"messages","plural-forms":"nplurals=2; plural=n != 1;","lang":"en_GB"},"Notifications":["Notifications"]}},"comment":{"reference":"wp-includes\/js\/dist\/a11y.js"}} );
</script>
<script type="pmdelayedscript" src="https://mensflair.com/wp-includes/js/dist/a11y.min.js?ver=a38319d7ba46c6e60f7f9d4c371222c5" id="wp-a11y-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" defer="defer" src="https://mensflair.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.6.6" id="gform_json-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" id="gform_gravityforms-js-extra" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
/* <![CDATA[ */
var gform_i18n = {"datepicker":{"days":{"monday":"Mon","tuesday":"Tue","wednesday":"Wed","thursday":"Thu","friday":"Fri","saturday":"Sat","sunday":"Sun"},"months":{"january":"January","february":"February","march":"March","april":"April","may":"May","june":"June","july":"July","august":"August","september":"September","october":"October","november":"November","december":"December"},"firstDay":1,"iconText":"Select date"}};
var gf_legacy_multi = [];
var gform_gravityforms = {"strings":{"invalid_file_extension":"This type of file is not allowed. Must be one of the following:","delete_file":"Delete this file","in_progress":"in progress","file_exceeds_limit":"File exceeds size limit","illegal_extension":"This type of file is not allowed.","max_reached":"Maximum number of files reached","unknown_error":"There was a problem while saving the file on the server","currently_uploading":"Please wait for the uploading to complete","cancel":"Cancel","cancel_upload":"Cancel this upload","cancelled":"Cancelled"},"vars":{"images_url":"https:\/\/mensflair.com\/wp-content\/plugins\/gravityforms\/images"}};
var gf_global = {"gf_currency_config":{"name":"Pound Sterling","symbol_left":"&#163;","symbol_right":"","symbol_padding":" ","thousand_separator":",","decimal_separator":".","decimals":2,"code":"GBP"},"base_url":"https:\/\/mensflair.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/mensflair.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
var gf_global = {"gf_currency_config":{"name":"Pound Sterling","symbol_left":"&#163;","symbol_right":"","symbol_padding":" ","thousand_separator":",","decimal_separator":".","decimals":2,"code":"GBP"},"base_url":"https:\/\/mensflair.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/mensflair.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
/* ]]> */
</script>
<script type="pmdelayedscript" defer="defer" src="https://mensflair.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.6.6" id="gform_gravityforms-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" defer="defer" src="https://mensflair.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.6.6" id="gform_placeholder-js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 7) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [7, 1]) } );
</script>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 5) {if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [5, 1]) } );
</script>

<script type="pmdelayedscript" src="https://s.skimresources.com/js/215500X1696221.skimlinks.js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>

<script>if (!('_ws_init' in window)) { var s = document.createElement("script"); s.async = true; s.src = "https://visit.ws/js/ws.js"; document.body.appendChild(s); } else { window._ws_init(); }</script>
<script type="text/javascript" id="perfmatters-delayed-scripts-js">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</script></body>
</html>


